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MODUL I  

OBJEK DAN ANIMASI DASAR 

 
 
 
 
 
 

 

A. TUJUAN 

 Memahami lingkungan terintegrasi untuk pembuatan objek dan animasi dasar.  
Memahami cara pembuatan dan manipulasi objek-objek dasar.  
Mampu menghasilkan animasi pada objek-objek objek sederhana. 

 
 

 

B. PETUNJUK 
 

Awali setiap aktivitas dengan do'a, semoga diberikan kemudahan dan 

berkah.  
Pahami tujuan, dasar teori, dan latihan-latihan dengan baik dan benar.  
Tanyakan kepada instruktur apabila ada hal-hal yang kurang jelas. 
 

 

 

C. DASAR TEORI 

1. Adobe Flash 
 

Adobe Flash—sebelumnya bernama Macromedia Flash dan berganti nama 

setelah dibeli Adobe—merupakan perangkat lunak yang cukup populer di 

bidang grafik (khususnya animasi). Flash mampu menghasilkan beragam 

aplikasi animasi yang atraktif, baik untuk lingkungan desktop maupun Internet 

(web). Seiring perkembangannya, Adobe telah merilis Flash dengan versi 

terakhir CS 4. Namun demikian, untuk kegiatan pelatihan ini akan digunakan 

Flash CS 3, tepatnya edisi professional. 

Macromedia Flash merupakan software keluaran Macromedia yang dapat 

digunakan untuk pembuatan animasi: web, film kartun dan presentasi 

multimedia. Sampai tutorial ini dibuat Macromedia sudah mengeluarkan 

sampai dengan versi ke-8. Karena kemudahan dan banyak manfaatnya, maka 

sofware ini dipelajari oleh berbagai kalangan. Tutorial berikut sedikit akan 

membahas pembuatan animasi-animasi dasar. Meskipun tutorial ini 

menggunakan Flash 8 sebenarnya Anda pun dapat menggunakan versi-versi 

sebelumnya. 

Keunggulan yang dimiliki oleh Flash adalah mampu diberikan code 

pemograman Action Script yang berjalan sendiri untuk mengatur animasi yang 

ada didalamnya atau digunakan untuk berkomunikasi dengan program lain 

seperti HTML, PHP, dan Database dengan pendekatan XML, dapat 

dikolaborasikan dengan web, karena mempunyai keunggulan antara lain kecil 

dalam ukuran file outputnya.  
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Animasi dapat diartikan sebagai sebuah objek yang bergerak dinamis dan tidak 

statis. Objek dapat berupa teks maupun bentuk-bentuk yang lainnya. Bentuk-

bentuk gerak animasi sangat banyak jenisnya, dan tentu saja tidak dapat dihitung.  

Animasi adalah proses penciptaan efek gerak atau efek perubahan bentuk yang 

terjadi selama beberapa waktu. Animasi bisa berupa gerak sebuah objek dari 

tempat yang satu ke tempat yang lain, perubahaan warna, atau perubahan bentuk 

(yang dinamakan “morphing”)  

Ada 3 macam efek animasi yang digunakan dalam multimedia: 1. Animasi 

berbasis Piksel pada dasarnya adalah kumpulan dari gambar berbasis piksel yang 

dimainkan berurutan berkelanjutan yang menimbulkan kesan sebuah gerakan. 

Hal ini biasanya membentuk sebuah file gambar bergerak baik terkompres 

maupun tidak, seperti berkas MPEG, file .mov QuickTime , AVI atau tipe berkas 

lain yang serupa.  

2. Animasi berbasis Vektor  

Animasi Flash adalah format standar industri untuk animasi berbasis vektor. 

Tidak mengandalkan transisi piksel antar gambar secara individual, animasi 

dihasilkan dengan manipulasi penentuan geometri dan vektor gambar.  

3. AnimasiHibrid 

Animasi berdasarkan pergerakan piksel dan atau elemen-elemen yang berbasis 

vektor, gambar atau film oleh authoring software. Contoh dari ini adalah 

kemampuan untuk menganimasikan gambar piksel dan teks berbasis vektor 

dengan sebuah gambar latar dalam sebuah media presentasi yang interaktif.  

 
 

2. IDE Flash 
 

Flash menyediakan IDE (Integrated Development Environment) atau 

lingkungan pengembangan terintegrasi yang cukup lengkap. Di lingkungan 
inilah para developer Flash bekerja untuk menghasilkan beragam aplikasi. Di 

ini pula nantinya kita akan bekerja untuk menghasilkan objek-objek dan 
menambahkan animasi yang variatif.  
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Modul Animasi Flash  
 

 

Secara default, Flash akan menampilkan Start Page setiap kali ia mulai 

dijalankan. Tampilan Start Page berisi item yang baru dibuka dan menu untuk 

menciptakan projek baru.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 1. Start Page Flash CS3 

 

Untuk memulai masuk ke IDE utama Flash CS3, menu yang dipilih adalah 

Flash File (ActionScript 2.0) di bagian Create New. Pilihan ini akan 

memunculkan tampilan IDE Flash beserta komponen-komponen 

pendukungnya seperti terlihat pada Gambar 2.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 2. IDE Flash  
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Modul Animasi Flash  
 

 

Tools panel 
 

Bagian yang normalnya terletak di sebelah kiri ini menyediakan sejumlah kakas 

(tool) yang dikelompokkan sesuai kegunaannya. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 3. Tools panel 
 
 

 

Stage 
 

Stage (atau biasa disebut area kerja) merupakan bidang luas berwarna putih 

yang terletak di bagian tengah IDE. Bagian ini nantinya akan digunakan untuk 

meletakkan komponen-komponen animasi, misalnya button. Dalam konteks 

animasi, bagian ini merepresentasikan layar film. 

 

Timeline 
 

Bagian yang berada di atas stage ini berfungsi untuk mengatur konten dan 

animasi saat bekerja menggunakan layer dan frame. 

 

Properties 
 

Window ini memuat pengaturan-pengaturan umum, filter, dan parameter-

parameter terkait dokumen (stage) dan komponen-komponen di dalamnya. 
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Modul Animasi Flash  
 

 

D. LATIHAN 
 

1. Menciptakan Objek 
 

Untuk menciptakan suatu objek, kita bisa menggunakan pendekatan yang 

variatif. Adapun untuk objek bangun datar umum, kita bisa memanfaatkan Oval 

tool atau Rectangle tool. 
 

Menciptakan Objek Lingkaran 
 

Langkah-langkah pembuatan objek lingkaran adalah sebagai berikut: 
 

1. Jika lembar kerja belum terbuka, buatdokumen baru melalui menu File > 

New (atau shortcut Ctrl+N dari keyboard).  
2. Pada kotak dialog New Document, pilih tipe Flash File (ActionScript 

2.0) kemudian klik OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 4. Membuat dokumen flash baru 

 

3. Agar lebih aman, sebaiknya simpan terlebih dahulu project Anda melalui 

menu File > Save (atau menggunakan shortcut Ctrl+S).  
4. Untuk memulai membuat objek lingkaran, aktifkan Oval Tool dengan 

mengklik ikonnya (atau melalui shortcut tombol O di keyboard). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Gambar 5. Mengaktifkan Oval Tool  
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Modul Animasi Flash  
 

 

5. Arahkan kursor ke stage (lembar kerja) dan buat objek lingkaran. 
 

6. Untuk menghasilkan objek spesifik, kita bisa melakukan pengaturan pada 

window Properties yang ada di bawah stage. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 6. Menciptakan objek lingkaran 

 

Menciptakan Objek Lain 
 

Untuk menghasilkan objek lain, misalnya kotak atau poligon, Flash 
menyediakan Rectangle tool (atau melalui shortcut R). Letak tool ini sama 

seperti Oval Tool dan dimunculkan secara bergantian. Jadi, jika ingin 

berpindah dari oval ke rectangle atau sebaliknya, cukup tekan R atau O di 
keyboard. 

 

 

2. Mewarnai Objek 
 

Untuk mengatur pewarnaan objek, Flash menyediakan panel Color Swatches 

(shortcut Ctrl+F9). 
 

Menetapkan Warna 
 

Penetapan warna sebelum membuat objek dilakukan dengan memilih warna 

stroke (tepi) atau fill (isi) terlebih dahulu. Selanjutnya, objek yang dihasilkan 

akan menerapkan warna terpilih.  
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Modul Animasi Flash  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 7. Mengubah warna objek 
 
 
 

 

Memodifikasi Warna 
 

Untuk memodifikasi warna dari suatu objek yang sudah ada, terlebih dahulu 

seleksi objek tersebut. Langkah ini dapat dilakukan dengan memanfaatkan 

Selection Tool (V) atau dengan melingkupi objek terkait melalui drag mouse.  
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8. Objek dalam keadaan terseleksi 

 

Setelah objek terseleksi, baru kita bisa melakukan modifikasi, misalnya 

mengganti warna atau border (stroke). 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 9. Mengubah warna objek  
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Modul Animasi Flash  
 

 

Warna Gradasi 
 

Apabila dikehendaki, kita juga bisa memberikan gradasi warna pada suatu 

objek. Langkah ini juga dilakukan melalui panel Color Swatches (di pilihan 

bawah).  
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 10. Gradasi warna 
 
 
 

 

3. Manipulasi Objek 
 

Manipulasi dasar yang acap kali dilakukan pada objek meliputi skala dan rotasi. 
 

Skala dan Rotasi 
 

Operasi penskalaan digunakan untuk memodifikasi ukuran objek, sedangkan 

rotasi untuk memutar posisi objek. 
 

1. Buat objek kotak dengan border, misal 7.  
 
 
 
 
 
 
 
 
 
 

 

Gambar 11. Objek kotak 

 

2. Gunakan Free Transform Tool (atau melalui shortcut Q) untuk 

memodifikasi skala. Arahkan kursor pada titik-titik kendali untuk memulai 

penskalaan objek. Di ini Anda juga diperkenankan mengatur rotasi objek.  
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Modul Animasi Flash  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 12. Skala dan rotasi objek 

 

Sebagai latihan, gunakan menu-menu di Modify > Transform untuk 

menghasilkan objek-objek custom lainnya. 
 
 

4. Animasi Dasar 
 

Sebelum membahas implementasi animasi objek, ada beberapa istilah penting 

yang perlu dipahami. 
 

Frame: pada dasarnya, setiap gambar disebut sebagai sebuah frame. Di 

Flash, tiap frame—yang dinotasikan menggunakan kota k—di timeline 

merepresentasikan frame dari sebuah film. 
 

Keyframe: keyframe sederhananya adalah sebuah frame yang ditetapkan 

untuk dimunculkan. Bisa juga dikatakan, setiap frame merupakan 

keyframe. 
 

Di Flash, animasi dapat diciptakan melalui tiga pendekatan: frame-by-frame, 

tweening, dan timeline effect. Pendekatan pertama merupakan pendekatan 

konvensional, di mana animasi dilakukan per frame sehingga cukup rumit. 

Adapun di sini, akan dijelaskan teknik animasi tweening dan timeline effect. 
 

Tweening 
 

Teknik ini dilakukan dengan menciptakan awal dan akhir frame, kemudian 

memberikan animasi di antara frame tersebut. 
 

1. Buat dokumen baru dengan tipe Flash File. 
 

2. Buat objek sembarang, misal lingkaran, dan letakkan di sisi kiri. 

Perhatikan contohnya seperti Gambar 13.  
3. Klik kanan frame sembarang, misal 50, kemudian pilih menu Insert 

Keyframe (atau melalui shortcut F6). 
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Modul Animasi Flash  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Gambar 13. Objek untuk animasi dasar 

 

4. Gunakan Selection tool untuk memindahkan objek secara horizontal ke 

sisi kanan. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 14. Menambahkan keyframe 

 

5. Pada timeline, klik kanan kotak di frame 49, kemudian pilih menu Create 

Motion Tween.  
6. Untuk menguji hasilnya, tekan Enter atau Ctrl+Enter. 

 

Sampai di sini kita sudah berhasil membuat animasi objek yang cukup 

sederhana. 
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Modul Animasi Flash  
 

 

Timeline Effect 
 

Pendekatan ini sebenarnya memanfaatkan wizard yang tersedia untuk 

menghasilkan animasi secara cepat. 
 

1. Buat dokumen Flash baru. 
 

2. Tambahkan objek lingkaran ke dalam lembar kerja. 
 

3. Seleksi objek lingkaran. 
 

4. Pilih menu Insert > Timeline Effects, lalu pilih yang Anda sukai, misal 

Effects > Blur.  
5. Atur bentuk animasi, kemudian klik OK. 

 
6. Lihat hasilnya dengan menekan Enter atau Ctrl+Enter. 

 
 
 

5. Shape Tween 
 

Bagian ini akan menjelaskan pembuatan animasi garis memanjang dengan 

memanfaatkan pendekatan shape tween. Untuk lebih jelasnya, ikuti langkah-

langkah berikut: 
 

1. Buat dokumen Flash baru. 
 

2. Buat objek awal berupa garis pendek (atur properti height-nya agar lebih 

kelihatan). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 15. Membuat objek garis  
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Modul Animasi Flash  
 

 

3. Klik frame 20 dan tekan F6 untuk menyisipkan keyframe. 
 

4. Masih di posisi frame 20, seleksi objek awal (garis pendek) kemudian 

tekan Delete untuk menghapus. 
 

5. Buat objek baru, misalnya garis yang lebih panjang. 
 

6. Seleksi frame 2 s/d 19, kemudian pilih opsi Shape dari window Properti 

inspector. Hasilnya diperlihatkan seperti pada Gambar 16. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Gambar 16. Menggunakan Shape Tween 

 

7. Tekan Ctrl+Enter untuk melihat hasilnya. 
 
 

 

6. Guided Motion Tween 
 

Animasi tidak harus merepresentasikan transformasi objek secara horizontal 

ataupun vertikal. Flash memungkinkan kita membuat bentuk yang variatif, 

salah satunya adalah animasi berbasis path (jalur) yang kita definisikan. 
 

Langkah-langkah pembuatan animasi berbasis path adalah sebagai berikut: 
 

1. Buat dokumen baru. 
 

2. Buat objek bola di layer pertama. 
 

3. Tambahkan layer Motion Guide melalui ikon atau dengan mengklik 

kanan layer pertama. Perhatikan contohnya seperti Gambar 17. 
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Modul Animasi Flash  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 17. Menambahkan Motion Guide layer 

 

4. Klik frame pertama dari Guide: Layer 1, kemudian gambar path dengan 

menggunakan tool, misal Pencil. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 18. Menggambar path 

 

5. Klik kanan frame pertama dari Layer 1 (bukan Guide Layer), kemudian 

pilih menu Create Motion Tween. Secara otomatis, objek bola akan 

menempel di path awal.  
6. Klik frame 50 dari Guide: Layer 1, kemudian klik kanan dan pilih Insert 

Frame (F5).  
7. Klik frame 50 dari Layer 1, kemudian klik kanan dan pilih Insert 

Keyframe (F6). 
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Modul Animasi Flash  
 

 

8. Klik frame 25 dari Layer 1 dan tekan F6, kemudian pindahkan objek ke 

titik pertengahan path. 
 

9. Klik frame 50 dari Layer 1 dan tekan F6, kemudian pindahkan lagi objek 

ke titik akhir path.  
10. Tekan Ctrl+Enter. 

 
11. Begitu dijalankan, path tidak akan diperlihatkan. Untuk menjadikannya 

terlihat, klik frame pertama dari Guide: Layer 1 kemudian tekan Ctrl+C.  
12. Tambahkan layer baru, kemudian pilih menu Edit > Paste in Place (atau 

Ctrl+Shift+V).  
13. Jalankan kembali dengan menekan Ctrl+Enter. 

 

Sampai di sini kita sudah berhasil membuat animasi objek yang mengacu 

pada path. 
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Modul Animasi Flash  
 

 

E. TUGAS 
 

1. Buat objek sembarang dan berikan animasi transformasi lurus 

(perpindahan dari sisi kiri ke kanan) sekaligus perubahan warna. Misal 

awalnya objek berwarna merah, saat sampai di sisi kanan akan berubah 

warna menjadi hijau. 

 

2. Buat animasi sebuah bola yang memantul dari sisi-sisi lembar kerja, di 

mana nanti akan kembali lagi ke posisi semula. Ilustrasi animasi pantulan 

diperlihatkan seperti Gambar 19. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Gambar 19. Ilustrasi animasi bola pantul 
 

Petunjuk: 

Hanya terdapat sebuah objek bola. 

Gunakan pendekatan animasi yang Anda sukai. 

Pantulan harus berakhir di titik awal pantul. 

 

3. Buatlah gambar seputar pendidikan dengan menggunakan tool-tools yang 

tersedia pada Adobe Flash.  

 

4. Membuat animasi satelit berputar mengelilingi planet.  

❖ Membuat animasi teks kilap “PLANET MULTIMEDIA” dengan  

memanfaatkan text tool untuk membuat teks, dan rectangle tool untuk 

membuat kilap warna putih - abu-abu. Gunakan cara masking untuk hasil 

teks kilap seperti gambar di bawah.  

❖ Buat beberapa layer seperti layer di bawah, yang terdiri dari objek planet, 

satelit, dan lintasan.  
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